• Announcements

    • Ouroboros

      Are you protected ?   11/05/18

      Your account security is important, read our guideline here :   
    • Otacon

      International Game Master Recruitment — Sethraliss & Sylvanas & Garrosh and Gul'dan   06/23/19

      Firestorm International is looking for Game Masters for Sethraliss, Sylvanas, Garrosh and Gul'dan. We're currently looking for members from all regions that wish to join our staff team. Each Game Master will be providing assistance to players through Forums, Discord and In-game tickets. Remember that there are requirements for the position. By signing up for the position you will gain experience with working in a team, and much more. Please put an effort into your application as we provide the general format for you and all you do is have to fill it in. Click here to read the requirements and apply!

Search the Community

Showing results for tags 'jaja'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General Information
    • Announcements
    • Information
    • Rules & Policies
    • Recruitment
    • Events
  • Development
    • Development News
    • Changelogs
    • Development Feedback
  • Community
    • Tutorials & Guides
    • Roleplay
    • Resources
    • Off Topic
    • Class Forums
    • Localized Forums
  • Realms' Forum
    • Sethraliss
    • Sylvanas
    • Gul'dan
    • Garrosh
  • Support
    • Forum's Archive
    • Suggestions
  • Firestorm Staff

Forms

There are no results to display.


Found 2 results

  1. When i press the "Play" button on the launcher nothing hapens, game doesnt launch ..even when i go in the game directory and press the wow icon nothing hapens ... this issue is only for legion every other expansion works perfectly .. i tough its something wrong with my pc and cant support the actual expansion and so i tried to launch retail and worked .. so i assume that issue is only on Firestorm ... i've played legion on firestorm before like 1-2 months ago and worked fine .. but now i cant launch the game ... it doesnt even show errors or any of that crap thats the part that triggers me i dont know what to do .. atleast if there were errors i would know what causes it... i have reinstalled the launcher countless times same for the legion expansion but nothing ... Please help ..
  2. Hi, Larva jaja. Thanks