• Announcements

    • Otacon

      International Game Master Recruitment — Sethraliss & Sylvanas & Garrosh and Gul'dan   06/23/19

      Firestorm International is looking for Game Masters for Sethraliss, Sylvanas, Garrosh and Gul'dan. We're currently looking for members from all regions that wish to join our staff team. Each Game Master will be providing assistance to players through Forums, Discord and In-game tickets. Remember that there are requirements for the position. By signing up for the position you will gain experience with working in a team, and much more. Please put an effort into your application as we provide the general format for you and all you do is have to fill it in. Click here to read the requirements and apply!
    • Otacon

      New Graphic Ideas   07/29/19

      If you are a Graphic Designer and want to volunteer to help the International Firestorm Staff with creating contents, make sure to take a look on that topic here.
    • Otacon

      Events on Twitch!   09/02/19

      The International Firestorm Staff is going to stream its Weekly Events on Twitch. For more information about our Twitch channel and the Weekly Events, you can check here.
    • Otacon

      Securing a Firestorm Account   11/16/19

      Securing your account is very important, so please read our guideline here:    
kidomaru56

LATENCY ISSUE

6 posts in this topic

The problem is I have an issue about my latency in specific location.

1. When in town (Orgrimmar, Dalaran), sometime my latency get 3-15k ms sometime it between 100-200 ms.

2. When playing on random battleground my latency is normal before meet enemy, when there's an enemy even one I can't even use my skill. It's very lag.

3. What happen in battleground also happen when I'm doing RDF.

4. My latency is normal if outside the area mention above.

This happen when I'm reach 110, before that I'm level up my character with no issue and no one using my internet connection. I'm downloading the full client through torrent. I'm living in Indonesia, someone said it's because the distance of server and my location. But I think my internet is good enough. I have 3 mb/s download speed.

Please help me. Thank you.

Share this post


Link to post
Share on other sites

I've noticed this as well for Broken Isles Dalaran/Stormwind even before i reached level 110. Zoning in causes my fps to drop immensely + when i try to move around it's laggy as hell for a bit until the lag/fps drop stabilizes. My internet is not great but it gets the job done for the most part.

Really couldn't say 100% what's causing this for you unfortunately.

Share this post


Link to post
Share on other sites
9 hours ago, Shalaya said:

I've noticed this as well for Broken Isles Dalaran/Stormwind even before i reached level 110. Zoning in causes my fps to drop immensely + when i try to move around it's laggy as hell for a bit until the lag/fps drop stabilizes. My internet is not great but it gets the job done for the most part.

Really couldn't say 100% what's causing this for you unfortunately.

Different with U, I got stuck at 60 FPS 'cause I'm enabling my vsync. But the lag is really kill my mood.

When in RBG my latency said only 190 but the lag is really painful. Only showing my char casting without showing casting bar.

Share this post


Link to post
Share on other sites

perma 200ms ftw

 

1 person likes this

Share this post


Link to post
Share on other sites

OK, so after long way of searching on google. I finally manage to fix this issue. Not entirely but I'll said playable. I'm watching a tutorial on youtube that using a VPN will reduce the latency. I don't understand this at all, 'cause when I using a VPN usually my internet connection will slowing down. But when I try this thing for the first time it's surprisingly work.

I download some free VPN, and set the IP to France. Now my latency when I play is about 250 - 1k. But most of the time on 330.

I don't know if it will work for people who have same problem with me, but better to try this things out.

Now the problem solved.

1 person likes this

Share this post


Link to post
Share on other sites

A bit late but there are some continental issues where America (mainly south america) is having issues connecting to Europe via the fast route. I dont know if its the ISP or if the undersea cables are being bitten by sharks :P

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.