• Announcements

    • Ouroboros

      Are you protected ?   11/05/18

      Your account security is important, read our guideline here :   
    • Otacon

      International Game Master Recruitment — Sethraliss & Sylvanas & Garrosh and Gul'dan   06/23/19

      Firestorm International is looking for Game Masters for Sethraliss, Sylvanas, Garrosh and Gul'dan. We're currently looking for members from all regions that wish to join our staff team. Each Game Master will be providing assistance to players through Forums, Discord and In-game tickets. Remember that there are requirements for the position. By signing up for the position you will gain experience with working in a team, and much more. Please put an effort into your application as we provide the general format for you and all you do is have to fill it in. Click here to read the requirements and apply!
zefnn2

help Bug You do not meet the requirements for this mount

11 posts in this topic

 

Yesterday admin gave me Slayer`s Felbroken Shrienker but today I can not use it wrote me "You do not meet the requirements for this mount". Do you know why ??

 

The moment they gave it to me I could use it and everything was right and then the server was restarted and I could not use it anymore. Allow me to use it only in Battleground ??

Edited by zefnn2

Share this post


Link to post
Share on other sites

It was a bug or something , if you didn't do the mage tower challenge you won't get the mount ...

Share this post


Link to post
Share on other sites

Well. i did the mage tower and i got the same bug. it appers after the update.

Share this post


Link to post
Share on other sites

 

fix it after restarting the server and for now there is no error

1 person likes this

Share this post


Link to post
Share on other sites
and today I can not use it again again I write this mistake

Share this post


Link to post
Share on other sites

Quess what guys... my mount dissapeared after the restart today...AGAIN....  Firestorm what are you doing cant i have my mount in my collection i did the mage tower?!

1 person likes this

Share this post


Link to post
Share on other sites
22 hours ago, ZTF said:

It was a bug or something , if you didn't do the mage tower challenge you won't get the mount ...

I have done the mage tower with every single class available to play, all have class mount except my monk, the mount unlearns upon logging( I have done the mage tower) and for my dk one day he has the mount the other day no again a day mount is there and a day the mount is gone

Share this post


Link to post
Share on other sites
22 hours ago, ZTF said:

It was a bug or something , if you didn't do the mage tower challenge you won't get the mount ...

I have done the mage tower with every single class available to play, all have class mount except my monk, the mount unlearns upon logging( I have done the mage tower) and for my dk one day he has the mount the other day no again a day mount is there and a day the mount is gone

 

 

Share this post


Link to post
Share on other sites

When i log on my warlock i get a message "you have unlearned Netherlord's Chaotic Wrathsteed" and can't use it obviously, even though i received it by doing mage tower months ago...

is anyone going to fix this?

Share this post


Link to post
Share on other sites

I have exactly the same problem!! I completed the mage tower fair and square with my warlock and now my mount is gone, wtf

Share this post


Link to post
Share on other sites

i have this issue too, but when i got into a bg it worked for some reason, once i got out again i cant use the mount, they need to fix this asap

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.