• Announcements

Sign in to follow this  
Followers 0
XXO

Latency !!!

10 posts in this topic

Latency in heroic antorus as well, 2k ms lag spikes while fighting bosses

Share this post


Link to post
Share on other sites

the problem is i got the same latency in rated  2s so in result u lose vs trash players cuz of it ...

same in bgs ...

Share this post


Link to post
Share on other sites

'retarded','facepalm' oh nvm from effect trash ...

Share this post


Link to post
Share on other sites

ping :25 ms from ookla mr moron !

Share this post


Link to post
Share on other sites

@XXO I see you definitely have no idea how things around lag and lagspikes work. Yes, it's possible to be something from Firestorm, but it also might be caused from your internet connection. Seeing 25 ms from speedtest proves nothing, because your speed might be fine, but you might be experiencing packet losses, which will cause you lagspikes. I don't think you can easily observe packet loss from speedtest. But it also might be a problem from Firestorm.. 

Share this post


Link to post
Share on other sites

There are two factors that cause lag. Your hardware and your connection. If you have a graphics card that cannot handle legion, simply lower your Settings. Though, in your case, I believe it is your connection. Do a speed test to France, and see how much you got. Do not perform a local/country speed test. There are some solutions that might help your latency if you believe your connection is not at fault. Try this service:

https://pingzapper.com/

Keep in mind that 200ms is not bad and I speak from experience on other games.

Share this post


Link to post
Share on other sites

hey @SuperSane yes you re right i dont know much about it but im sure its not from my net

i play in 3 other private servers with latency under 80ms when i log in firestorm i get +180ms

Share this post


Link to post
Share on other sites

@Sam its really bad if you play rated arena for exemple

200ms vs 30ms 

you ll never interrupt in time... etc

Share this post


Link to post
Share on other sites

@XXO, I think you are right about the latency, My latency is also at 200ms now. I did not notice it before.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0