• Announcements

Sign in to follow this  
Followers 0
trinirambo1

Traits

9 posts in this topic

hi i have a problem with Mistweaver Spec when I try to add any Traits nothing happens. I have over 972M Artifact Power and all 3 Relics however i cannot add a single trait. whenever i try to add traits nothing happens. I am able to add traits to Windwalker and Brewmaster without any problems however Mistweaver Spec will not allow me to....please help. Character name Kungfubich

WoWScrnShot_121218_190702.jpg

WoWScrnShot_121218_190719.jpg

WoWScrnShot_121218_190733.jpg

Share this post


Link to post
Share on other sites

Go to Argus and get those 5ilvl traits with all 3 relics @ Vindicaar's Netherlight Crucible. Then relog, go to your Class Hall and then try to pick traits. If that doesn't help, switch specs and relog. If that doesn't help, keep respecing and reloggin' untill it does.

Share this post


Link to post
Share on other sites

thanks i will try that and post results.

Share this post


Link to post
Share on other sites

i was able to get 1 rank in two different traits however i could not get more than 1 rank so i relogged and lost the ranks i bought but look at my AP amount its less. so it used up some of my AP but still unable to purchase traits.

WoWScrnShot_121318_173345.jpg

Share this post


Link to post
Share on other sites

I had the same problem with my two other artifact weapons. I "fixed" one by going to the Netherlight Crucible and using the +5 ilvl traits, the other one acted like yours.

Relogging and respeccing did not fix it for my third artifact.

Unequipping the artifact weapon (put it in your bag) while in the according specc and then relogging and re-equipping it again solved it for me.

Best regards

Share this post


Link to post
Share on other sites

thanks for your input i will try that and post results.

Share this post


Link to post
Share on other sites
17 hours ago, Dayblind said:

I had the same problem with my two other artifact weapons. I "fixed" one by going to the Netherlight Crucible and using the +5 ilvl traits, the other one acted like yours.

Relogging and respeccing did not fix it for my third artifact.

Unequipping the artifact weapon (put it in your bag) while in the according specc and then relogging and re-equipping it again solved it for me.

Best regards

with the artifact weapon unequipped and in my bags while in the spec and relogging and re-eqipping it again did indeed solve my problem....many thanks to you.../tips hat

  

WoWScrnShot_121418_163900.jpg

Share this post


Link to post
Share on other sites

You're welcome, glad i could help.

Have a nice pre xmas week.

Best regards

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0