• Announcements

    • Otacon

      International Game Master Recruitment — Sethraliss & Sylvanas & Garrosh and Gul'dan   06/23/19

      Firestorm International is looking for Game Masters for Sethraliss, Sylvanas, Garrosh and Gul'dan. We're currently looking for members from all regions that wish to join our staff team. Each Game Master will be providing assistance to players through Forums, Discord and In-game tickets. Remember that there are requirements for the position. By signing up for the position you will gain experience with working in a team, and much more. Please put an effort into your application as we provide the general format for you and all you do is have to fill it in. Click here to read the requirements and apply!
    • Otacon

      New Graphic Ideas   07/29/19

      If you are a Graphic Designer and want to volunteer to help the International Firestorm Staff with creating contents, make sure to take a look on that topic here.
    • Otacon

      Securing a Firestorm Account   11/16/19

      Securing your account is very important, so please read our guideline here:    
    • Otacon

      Boost Firestorm Discord / VIP   12/20/19

      Be ready to boost our Discord and in return, you become a VIP. You can read about that here.
Sign in to follow this  
Followers 0
kaidenjames

Game won't launch

8 posts in this topic

Hey everyone. trying to play Legion and I can't get the game to launch. I'm using the launcher and the torrent full game download. When I launch from the launcher I get a window asking me to choose my language. I choose English and hit okay. After that the launcher says it has to download some files but then nothing happens. My wow.exe will show up in the task manager but never loads. I left "running" for 2 hours yesterday and nothing happened.

I've tried deleting everything official (battle.net, blizzard and official wow) and I've also tried downloading the game through the launcher. Neither seem to help. This is weird cause I've played this server before on this same PC. Any help would be great. Thanks everyone.

Share this post


Link to post
Share on other sites
22 hours ago, kaidenjames said:

Hey everyone. trying to play Legion and I can't get the game to launch. I'm using the launcher and the torrent full game download. When I launch from the launcher I get a window asking me to choose my language. I choose English and hit okay. After that the launcher says it has to download some files but then nothing happens. My wow.exe will show up in the task manager but never loads. I left "running" for 2 hours yesterday and nothing happened.

I've tried deleting everything official (battle.net, blizzard and official wow) and I've also tried downloading the game through the launcher. Neither seem to help. This is weird cause I've played this server before on this same PC. Any help would be great. Thanks everyone.

Download the following files:
https://cdn.discordapp.com/attachments/456860411682095124/457547475969114132/config.rar
https://cdn.discordapp.com/attachments/376808947992100867/463974179642015744/FS735.wtf

Extract the config.rar to Data folder
and copy FS735.wtf to WTF folder
after that remove the read only
from the world of warcraft folder
and execute either Firestorm-64.exe as admin or Firestorm Launcher as admin

 

Try this fix, i found on the forum, dont remember who posted, but worked for me!

3 people like this

Share this post


Link to post
Share on other sites

Oh my god I have been looking for this solution all over thank you so much

 

1 person likes this

Share this post


Link to post
Share on other sites

This doesnt work for me help please

 

2 people like this

Share this post


Link to post
Share on other sites

When I followed the instructions it stopped asking what language I wanted but now it doesnt launch at all, just runs in the background.

1 person likes this

Share this post


Link to post
Share on other sites

Dont worry, the first time is nm, It can take around 20 minutes, only wait

1 person likes this

Share this post


Link to post
Share on other sites

ok so it launched but it launched into the blizzard server. Is there a realmlist thing I need to add?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0